public class GameManager : MonoBehaviour
{
public bool EnableHighContrast;
public bool PlayerWon;
public float PlayerUnitsMoved;
public int PlayerDeathCount;
public float PlayerHealth;
public void PlayerTakeDamage(float damage)
{
PlayerHealth -= damage;
if (PlayerHealth < 0)
{
PlayerDieAndRespawn();
}
}
public void PlayerDieAndRespawn()
{
return;
}
}
You are correct about it allowing you to have zero health and not die, but whether or not that's the correct behavior will depend on the game. Off the top of my head I know that Street Fighter, some versions at least, let you cling to life at zero.
I know this is /c/Progammerhumor, but I wanted to pull on this thread a little bit for my own edification. I'm a Python guy and have been a while, but I've dabbled in other languages. The screenshot says "MonoBehaviour" which makes me assume this is mono or a .Net-like language (you know what happens when you assume).
If your player health is a float, would mono or .Net have an issue comparing the float with integer zero "0"? I mean, it seems like floating point precision may make it impossible for it to ever "equal" integer zero, but it also seems like the code isn't accounting for that precision error.
This won't work if you can ever take more than 1 damage. If you were at 1 and received 2 damage you would become invincible. You'd want to do less than or equal to.
Well if you have a "down but not dead" condition then yes, you could escape a fight with 0 health (assuming you have teammates/pawns that can save you).
I genuinely believe something like this is what some of my professors wanted me to submit back in school. I once got a couple points off a project for not having a clarifying comment on every single line of code. I got points off once for not comment-clarifying a fucking iterator variable. I wish I could see what they would have said if I turned in something like this. I have a weird feeling that this file would have received full marks.
Did you have my professor for intro to C? This guy was well known for failing people for plagiarism on projects where the task was basically "hello world". And he disallowed using if/else for the first month of class.
This is something that can easily get refactored, because the purpose of alia the variables is right there in the name. This is way better that spending three days to try to figure out what the purpose of var1 is.
Nah, refactoring this would be a bitch. Your function name contains everything that happens in the function. Which means if you add something to it, you also have to change the name of the function. So CallThisWhenThePlayerTakesDamageAndIfThePlayerHealthIsLessThanZeroThenAlsoTheyDie would have to go to something like CallThisWhenThePlayerTakesDamageAndIfThePlayerHealthIsLessThanZeroThenAlsoTheyDieAndIncrementTheTotalDamageTakenCounter if you added something else.
I mean, this is overdoing it a bit and the "thisVarMakesItSoThat" part is redundant, but other than that those are very descriptive property- and method names, which is not a bad thing.
It wouldn't need to say HighContrastForAccessibilityPurposes though, it would ideally just be HighContrast, and the "for accessibility purposes" would be a comment, right?
Variable names shouldn't need comments, period. You don't want to look it up every time this variable is used in code, just to understand what it holds. Of course there are always exceptions, but generally names should be descriptive enough to not need additional explanation.
And context can also come from names of other things, e.g. name of a class / namespace that holds this variable. For example AccessibilitySettings.HighContrast, where AccessibilitySettings holds all options related to accessibility.
Well the "Purposes" can definitly be dropped. I guess "HighContrast" would be enough if there is only a single high contrast setting, but if there are multiple then I think "HighContrastForAccessibility" would be totally fine.
The real naming fail is calling the class "GameManager", still my number one pet peeve.
With a class name as vague as that you would have to add tons of information into the variable name. (Also the class name begs for unorganized code. I mean name one function or variable that you could not justify putting into the "GameManager" class. After all if it's managing the game it could justifiably perform any process in the game and access any state in it.)
Once you put the first bool into a class with a name like AccessibilitySettings, calling it something like HighContrast is completely sufficient.
We've all been guilty of these mistakes, naming stuff is hard, structuring your project is hard, learning the grains of a language takes time. But comments like these are golden nugets, some might read this and think "oh yeah, this makes sense" and rethink their whole methodology of naming and structure. You might have pushed someone reading your comment, to think more about these things.
Unity actually gives any class with the name GameManager a special gear icon. You cant just forgo the cool gear icon!
(Its not too terrible from an organizational standpoint because most of the scripts are attached to game objects. MonoBehavior is a component of GameObject. For instance, you’d never have player movement in the GameManager class, you would put it in the component class attached to the player character GameObject.)
you’d never have player movement in the GameManager class
You want to bet? (Source: I teach game programming on a college level.)
But yeah, your comment about the gear icon is sadly more true than people may realize.
Game developers do questionable things. => Engine developers cater to people. => Students argue that if something is supported it can't be that bad.
Sometimes it feels like fighting windmills.
At my first job I was working on an MMO and we had a DatabaseManager class with 10k+ lines of code. Less than the first 200 lines actually used any of the members of that class.
Until they find out that the way to descriptive variables or functions needs to be extended with new business logic requiring renaming of functions again and again.
I think maintaining code with this level of verbose naming, will be a pain over time. If they don't let the naming slip, and then they could as well use cryptic 3 letter names.
Hot take, but the main problem with this is that you have to type variables or use them in larger expressions. Otherwise I like it.
These would make a great mouseover text. I don't know if there's any standard way to support that. Actually, how come coding in non-plaintext formats never took off?
I need like a tutorial on IDEs, because clearly I'm using them wrong. Or I tend to work on things that are poorly documented and just haven't been able to take advantage, I guess that's possible.
I’m already annoyed by the end of public static final string that the variable name doesn’t even bother me in these sorts of langauages. All things should be public, static, & final, by default so they aren’t necessary to write. You should only have to write what unsafeties you are opting into.
When the variable name is the description that should be in the comments.
Idea: Comments that automattically populate the end of any line a given variable is invoked on, including spelling out formulas from that line. ie:
float y=mx+b // (cartesian y value)=(slope)(cartesian x value)+(cartisian y-intercept)
"Duplicated" coments not actually in the file, but specified witt the creation of such variables and spread around by the code editor /IDE.
Then, you could take those comments, and have the compiler use them to ensure you're using the right variable in the right place. Oh wait, we just invented a type system.