Yeah, a name should describe what it is or does, so if you have two turtles, and let's say turtle1 wants to shit on turtle2's lawn, you could name them shittingTurtle and victimTurtle. If the name alone tells you what its purpose is, that saves a lot of time for people looking at your code.
Is_Turtle is not a bad variable name because it tells you it is a Boolean with "is" and that the Boolean tells you whether something is a turtle or not.
Also, depending on the language, I suggest either camelCase or snake_case naming of variables. PascalCase is usually for defining classes or in case of C#, methods.
I'm gonna be honest I just used Turtle ad an example:X .. when it's actually like a GoldCost, GoldC and GoldH. Where GoldR is a reset var and GoldC is the paid value. GoldCost is self explanatory but I really spagettied it up XD...
When you start learning about different paradigms, you'll likely learn much more about inheritance when learning about the Object Oriented design paradigm.
To overly simplify, you create objects that inherit attributes from other objects. It's for instance a way to create reusable patterns, that have stronger and more reliable data structures.
I made the joke comment, because for instance, you could create a Turtle class, and always know it was a Turtle. Again, an oversimplification.
EDIT: I should also add that for some reason OOP is an oddly divisive subject. Developers always seem to want to argue about it.
If we're talking mathematicians, you just know it's going to be ω-nested recursive functions any moment now. Just be grateful it's not all n with polynomial subscripts or something.
I always make sure my variables are named in ways I can remember what they're for. The only time I just use generic var1, var2, etc is if I am experimenting with a function I've never used before and wanna play around with it to see how it's used.
This should be easily read by others but there could be times where it's an inside joke.
All great code started out as a shitty work-around that happened to work.
(I say this as someone with one of the more prestigious pedigrees in "not writing shit code". All the theory I've learned helps, but at the end of the day the most important qualities of a line of code are: whether it got the job done, and whether is was obviously correct enough that the next developer left it alone.)
All these jokes about naming variables and yet no serious suggestions that if you have a turtle2, what you really need is a turtle array. I like to block out all the memory I'll need for the whole program up front, put it all in one big array, and then I can use clean, easy to remember numbers for all my variables!
I remember an old mentor programmer I had who basically described his job as building an addition to an addition to an addition on a tree house built in a twig.